E-Cig-Reviews.com - Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

FULL LIST OF SUPPLIER DISCOUNT CODES - CLICK

20% Discount Code Added For WWW.JACVAPOUR.COM - ECR69

15% Discount Code Added For WWW.T-JUICE.COM - ECR69

10% Discount Code Added For WWW.MIRAGECIGARETTES.CO.UK - MC69

Pages: [1]   Go Down

Author Topic: Smoktech magneto not firing  (Read 3955 times)

Jimbojones

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 35
  • Windowlicker
Smoktech magneto not firing
« on: August 11, 2014, 03:31:12 PM »

Today i received my first MOD, the smoktech magneto which i ordered from ukecigcabin but they're on holiday till friday so no customer support until then :S
I also purchased a efest 18350 battery charger and 510/ego adaptor so i can fit my kanger aerotank mini, aspire bdc and iclear 16 clearomisers to it. It doesnt fire, ive checked all the connectors are tight and made adjustments to the centerpin to avoid battery rattle. Ive tested the ego adaptor on my ego battery and that fires every time so i think either its the battery or the mod its self, has anyone had problems with this at all?
Logged

Rocc

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 758
  • The best tea is cold
Re: Smoktech magneto not firing
« Reply #1 on: August 11, 2014, 03:57:48 PM »

make sure the positive connector on both the mod and the atomizer are making contact. even if it fire on one mod the connector on the other mod maybe lower and need to be moved alittle  ;D
Logged

justin case

  • FISH!
  • Diamond Member
  • ****
  • Offline Offline
  • Posts: 9944
  • Strong In Body. Strong In Mind. And A Scum Lord.
Re: Smoktech magneto not firing
« Reply #2 on: August 11, 2014, 04:04:27 PM »

i think you have to remove the top cap and screw your atomiser on, then screw up the center pin until you feel it meet the atomiser pin.....then put it all together and it should work.
Logged

Jimbojones

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 35
  • Windowlicker
Re: Smoktech magneto not firing
« Reply #3 on: August 11, 2014, 05:05:56 PM »

Ive adjusted the center and ive managed to get it to fire, but its not 100% if i hold the mod up slightly above horizontal it fires more often so im guessing as rocc said the pin isnt quite long enough to make contact with both atomizer and battery?
Logged
Pages: [1]   Go Up