E-Cig-Reviews.com - Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

FULL LIST OF SUPPLIER DISCOUNT CODES - CLICK

20% Discount Code Added For WWW.JACVAPOUR.COM - ECR69

15% Discount Code Added For WWW.T-JUICE.COM - ECR69

10% Discount Code Added For WWW.MIRAGECIGARETTES.CO.UK - MC69

Pages: [1] 2 3 4   Go Down

Author Topic: Spheroid arrived, as predicted I suck  (Read 6664 times)

Tigggger

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 54
Spheroid arrived, as predicted I suck
« on: October 31, 2012, 04:56:29 PM »

OK, so it arrived this morning and was eager to get up and running, watched scott's video a few more times and off I went.

Coiling my first wick seemed to go ok (after going to the shop to buy a desktop magnyfier), first problem came trying to move the wick and coil on top of the posts, during this one of the wires from the post snapped.

Next go I held the wick a bit further away while fastening the wires, success managed to get it on top, but during the tweaking the nut had come loose and the wire dropped out, it was too short to try and reconnect so in the bin with the first attempt, this same failure was repeated again

Wrapped both wires clockwise this time and again tightened with pliers and they held firm. Placed some drops on the wick/coil and fired it up and there was vapour. Few more drops checked the resistance which was fine and fired up again. Soaked all the filler material and left it for a while, once I figured it had soaked long enough took my first vape and yuck a revolting taste.

Took it to pieces dropped plenty of juice on the wick and kept firing it figuring it was new and might need a few goes, but the awful smell won't go away and I've been doing it for ages now. Can't describe the actual taste/smell so appreciate it wont be easy for someone to say what's wrong. Coils are all glowing evenly

Any suggestions gratefully received.
Logged

a1laserboy

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 688
  • frikkin lasers!
Spheroid arrived, as predicted I suck
« Reply #1 on: October 31, 2012, 05:10:46 PM »

I'm glad it's not just me mate. Not saying im glad youre having problems of course. It looks lovely but I can't get mine working right either.

I get a kind of burned type taste but its hard to describe.

Logged

ukric

  • Platinum Member
  • ******
  • Offline Offline
  • Posts: 4543
  • Chasing Da Clouds
Spheroid arrived, as predicted I suck
« Reply #2 on: October 31, 2012, 05:44:19 PM »

Sounds like it ain't wicking well
Logged

Tigggger

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 54
Re: Spheroid arrived, as predicted I suck
« Reply #3 on: October 31, 2012, 05:51:15 PM »

Sounds like it ain't wicking well

The awful smell persists even when dripping directly on the coil.
Logged

ukric

  • Platinum Member
  • ******
  • Offline Offline
  • Posts: 4543
  • Chasing Da Clouds
Spheroid arrived, as predicted I suck
« Reply #4 on: October 31, 2012, 05:52:50 PM »

Where up north is one from?
Logged

Tigggger

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 54
Re: Spheroid arrived, as predicted I suck
« Reply #5 on: October 31, 2012, 05:53:54 PM »

I'm in Preston, Lancs
Logged

JamesC

  • Full Member
  • ***
  • Offline Offline
  • Posts: 191
  • Tickle tickle tickle
Re: Spheroid arrived, as predicted I suck
« Reply #6 on: October 31, 2012, 05:54:47 PM »

That was speedy delivery Tigggger, im still waiting for mine.
Logged

ukric

  • Platinum Member
  • ******
  • Offline Offline
  • Posts: 4543
  • Chasing Da Clouds
Spheroid arrived, as predicted I suck
« Reply #7 on: October 31, 2012, 06:10:30 PM »

Ahh I was gonna say pop over with it but that's a bit further than its probably worth.
Logged

ukric

  • Platinum Member
  • ******
  • Offline Offline
  • Posts: 4543
  • Chasing Da Clouds
Re: Spheroid arrived, as predicted I suck
« Reply #8 on: October 31, 2012, 06:11:03 PM »

Are you both using the wick that came with it?
Logged

Tigggger

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 54
Re: Spheroid arrived, as predicted I suck
« Reply #9 on: October 31, 2012, 06:21:11 PM »

Yes it's my first rebuildable so only have what came in the kit. Appreciate the offer of help, you are about an hour away if I have no joy in a few days and it's doesn't get smashed with a hammer may take you up on that :)
Logged

ukric

  • Platinum Member
  • ******
  • Offline Offline
  • Posts: 4543
  • Chasing Da Clouds
Re: Spheroid arrived, as predicted I suck
« Reply #10 on: October 31, 2012, 06:30:12 PM »

For what it's worth I binned the wick that came with it as it went black when I burnt it.
Logged

a1laserboy

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 688
  • frikkin lasers!
Re: Spheroid arrived, as predicted I suck
« Reply #11 on: October 31, 2012, 06:46:33 PM »

I'm also using what came with it. Wick is soaking wet but instantly black when fired, even at low volts with 2.4 ohm coil.
Logged

Chunky

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 703
  • A vape in the hand is worth ....
Re: Spheroid arrived, as predicted I suck
« Reply #12 on: October 31, 2012, 06:55:50 PM »

Sorry you are getting problems with the atty...i can only say that i had to make minor adjustments once it was firing up. How many coils are you putting on with the wire. If it is firing up im not sure you are to far off a good vape. I used the wick and wire supplied with good results. What resistance are you getting, and is the wick getting juice from the wadding in the tank. Are there hot spots showing or is it an even burn....so sorry its not working right yet.  ???
Logged

Tigggger

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 54
Re: Spheroid arrived, as predicted I suck
« Reply #13 on: October 31, 2012, 07:49:16 PM »

I'm doing 4 turns, looks exactly like the one in scott's video, think it was 1.5ohms on the last attempt.

After the first horrible mouthfull I haven't used the tank or tried inhaling it, I've just been soaking the wick and firing it, there is plenty of vapour is just smells awful.

Quote
Are there hot spots showing or is it an even burn....so sorry its not working right yet.

This is the bit I'm struggling on as a newbie as I don't understand fully what it should or shouldn't look like. My coil isn't glowing anywhere when I fire it. Obviously if keep the button pressed for a while, it uses the juice up, starts glowing evenly and then catches fire just like in the video :) I presume that means no hotspots
Logged

itsmeitis

  • Diamond Member
  • *******
  • Offline Offline
  • Posts: 19147
  • lapsus linguae
Re: Spheroid arrived, as predicted I suck
« Reply #14 on: October 31, 2012, 08:08:32 PM »

what device are you using ?
Logged
Pages: [1] 2 3 4   Go Up